asterisk-chan-dongle-alpine/APKBUILD

32 lines
786 B
Plaintext

# Maintainer: Alexander Zhirov <alexander@zhirov.kz>
pkgname=asterisk-chan-dongle
pkgver=1.1
pkgrel=0
pkgdesc="PXE data restore"
url="https://git.zhirov.kz/forks/asterisk-chan-dongle"
arch="aarch64"
license="GPL"
source="${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
depends="asterisk"
makedepends="
automake
autoconf
sqlite-dev
gawk
asterisk-dev
"
builddir="${srcdir}/${pkgname}"
build() {
./bootstrap
./configure --with-astversion=18.15.1
make
}
package() {
install -Dm755 "${builddir}/chan_dongle.so" "${pkgdir}/usr/lib/asterisk/modules/chan_dongle.so"
}
sha512sums="
23d9589a5215185692fa091282d5e4c96fe44d7aafaefcc910d71cc65dd5e646e8ee0b31bf6daca0b6896c5d0287a6421527c1fb207144cd478d3ab5eb90205c ${pkgname}-${pkgver}.tar.gz
"